summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-08-19 17:31:35 -0400
committerJean Lucas2019-08-19 21:00:42 -0400
commit1dc40f0fe3b73963c5a55e382f66f5c08f77fc33 (patch)
tree9052aa45bd3f9f80827eccc17545966ea4ebb75c /PKGBUILD
parent04adc673058d021af5a77c359956bf8288e995d5 (diff)
downloadaur-1dc40f0fe3b73963c5a55e382f66f5c08f77fc33.tar.gz
6.5.4
- Use a version release - Update deps - Build/install man page - Add check() - Install readme/samples/license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 51 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a56caee1084..b69f8c2887ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,69 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=parsedmarc
-pkgver=0+584+536b94f
-_commit=536b94ff9056c20cec846e41b7ca7853b7cc678f
+pkgver=6.5.4
+_commit=6efec4e6334bff28f7fd4ee89932d08307a70289 # Upstream does not tag releases - cherry-pick has commit message of release version
pkgrel=1
pkgdesc='Python package and CLI for parsing aggregate and forensic DMARC reports'
arch=(any)
url=https://domainaware.github.io/parsedmarc
license=(Apache)
-depends=(python-dnspython
- python-requests
- python-publicsuffix
+depends=('python-tqdm>=4.31.1'
+ 'rstcheck>=3.3.1'
+ python-pygments
+ 'python-dnspython>=1.16.0'
+ 'python-expiringdict>=1.1.4'
+ 'python-urllib3<1.25'
+ 'python-urllib3>=1.21.1'
+ 'python-requests>=2.2.16.0'
+ python-publicsuffix2
'python-xmltodict>=0.12.0'
- python-pygeoip
- python-dnspython
- python-imapclient
- python-mail-parser
- python-dateparser
- python-elasticsearch
- python-elasticsearch-dsl
+ 'python-geoip2>=2.9.0'
+ 'python-imapclient>=2.1.0'
+ 'mailparser>=3.9.2'
+ 'python-dateparser>=0.7.1'
+ 'python-elasticsearch<7.0.0'
+ 'python-elasticsearch>=6.3.1'
+ 'python-elasticsearch-dsl<7.0.0'
+ 'python-elasticsearch-dsl>=6.3.1'
+ 'python-kafka>=1.4.4'
+ 'python-mailsuite>=1.1.0'
+ python-nose
+ python-pygments
flake8
+ python-collective-checkdocs
+ python-jinja
+ python-packaging
+ python-imagesize
+ python-sphinx-alabaster-theme
+ python-babel
+ 'rstcheck>=3.3.1'
python-sphinx
python-sphinx_rtd_theme
- python-collective-checkdocs
python-wheel
- rstcheck
- 'python-tqdm>=4.31.1'
- 'python-kafka>=1.4.4'
- 'python-elasticsearch-dsl<7.0.0'
- 'python-elasticsearch<7.0.0')
-makedepends=(git python-setuptools)
-source=(git+https://github.com/domainaware/parsedmarc#commit=$_commit)
-sha512sums=('SKIP')
+ python-codecov)
+makedepends=(python-setuptools)
+source=($pkgname-$pkgver.tar.gz::https://github.com/domainaware/parsedmarc/archive/$_commit.tar.gz)
+sha512sums=('a8ef754b9838c794afcffbf35620f48f83bf6aa7ebab1f2521bcc26cd481ae9761d80333fa2a67462993d1c30bc76293acf44ec2908b82390def1bd8a442070e')
+
+build() {
+ cd $pkgname-$_commit
+ python setup.py build
+
+ cd docs
+ make man
+}
-pkgver() {
- cd parsedmarc
- printf 0+%s+%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+check() {
+ cd $pkgname-$_commit
+ python tests.py || warning "Tests failed"
}
package() {
- cd parsedmarc
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/parsedmarc
+ cd $pkgname-$_commit
+ python setup.py install --root="$pkgdir" -O1
+ install -Dm 644 docs/_build/man/parsedmarc.1 -t "$pkgdir"/usr/share/man/man1
+ install -Dm 644 README.rst -t "$pkgdir"/usr/share/doc/$pkgname
+ cp -a samples "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}