summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbuck-yeh2021-01-11 03:01:15 +0800
committerbuck-yeh2021-01-11 03:01:15 +0800
commit5af37877b981b123369a492bd4f7bd78738c6247 (patch)
treef0078a719e3be4d6a0690a10f65d1809cdbfd781 /PKGBUILD
parent0358db3c0092defda8962e95cb4a6caf4d0300c2 (diff)
downloadaur-5af37877b981b123369a492bd4f7bd78738c6247.tar.gz
Improve parsergen & scannergen to have better quick guide experience:
1. 🆕 Add Quick Guide to README.md 2. 🆕 Add version number to the banner of every generated C++ file. 3. 🆕 example/MinLang/README.md 4. ✍️ Obsolete Positional argument <ScannerBase> is required Type "scannergen -h" to read the help option %CPP_INCLUDE 5. ✍️ Default parser class name when absent. 6. ✍️ GLR context support is complete. It has been broken for a long time. 7. ✍️ Default to 8. ✍️ Legacy code mildly modernized. 9. ✍️ Encourge to add RE_Suite.txt as Positional argument <ScannerBase> is required Type "scannergen -h" to read the help argument instead of using #include "RE_Suite.txt" and -I flag. 10. ✍️ All example parsers re-generated. 11. ✍️ Package desc & version number source in PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c58ac7f8c6a..876dd79a5f63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,17 @@
# Maintainer: Buck Yeh <buck.yeh at gmail dot com>
pkgname=parsergen
-pkgver=1.5.1
+pkgver=1.6.0
+#pkgver=VERSION
pkgrel=1
epoch=
-pkgdesc='LR1/GLR parser generator into Modern C++ code which must be built with bux library'
+pkgdesc='Self-hosted LR parser generator in C++20'
arch=('x86_64')
url='https://github.com/buck-yeh/parsergen.git'
license=('MIT')
groups=()
depends=('fmt')
-makedepends=('cmake' 'make' 'gcc' 'git' 'binutils' 'fakeroot' 'sed' 'gawk')
+makedepends=('cmake' 'make' 'gcc' 'git' 'binutils' 'fakeroot' 'gawk')
checkdepends=()
optdepends=('bux: To build the generated code with')
provides=()
@@ -48,7 +49,7 @@ if [[ ! "$pkgver" =~ ^[0-9]+\.[0-9]+\.[0-9]+$ ]]; then
s/^ *VERSION_MAJOR *= *\([0-9][0-9]*\).*/\1/p
s/^ *VERSION_MINOR *= *\([0-9][0-9]*\).*/.\1/p
s/^ *VERSION_RELEASE *= *\([0-9][0-9]*\).*/.\1/p
-' ParserGen/main.cpp); do _ret="$_ret$i"; done
+' ParserGen/Output.h); do _ret="$_ret$i"; done
echo "$_ret"
}
fi