summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGennadiy Mykhailiuta2023-06-16 11:02:34 +0000
committerGennadiy Mykhailiuta2023-06-16 11:02:34 +0000
commitd1cdeec6f81fe3eaf0888fc31da09842b17e28f8 (patch)
treeb64a89d15fb5361914cf540159c6272666fa16fb /PKGBUILD
parenta2d6643afe00b4d6f2be7011c36dd2693ab5460d (diff)
downloadaur-d1cdeec6f81fe3eaf0888fc31da09842b17e28f8.tar.gz
Fix git submodule fetch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee98f7446228..67ab51d68ba4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=parted-git
-pkgver=3.4.r50.gb20227a
+pkgver=3.6.r4.g60b3300
pkgrel=1
pkgdesc="A program for creating, destroying, resizing, checking and copying partitions"
arch=('x86_64')
@@ -23,17 +23,19 @@ pkgver() {
cd $pkgname
git describe --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
}
- prepare() {
+
+prepare() {
cd $pkgname
git submodule init
git config submodule.gnulib.url "${srcdir}/gnulib-git"
+ git config protocol.file.allow always
git submodule update
}
build() {
cd $pkgname
- ./bootstrap --no-git --gnulib-srcdir=gnulib
+ ./bootstrap --no-git --gnulib-srcdir=gnulib
./configure \
--prefix=/usr \
--sbindir=/usr/bin \