summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGergely Imreh2019-02-07 10:32:22 +0000
committerGergely Imreh2019-02-07 10:32:22 +0000
commit641a47e36a03abf7d44340c7a27ea37b324e1090 (patch)
treeaab5cf15b49fe00ac2a4d2942c7d2c44dc3604d4 /PKGBUILD
parentd93f76c1d79ba26f54ae0f4bd46fcd53003597f0 (diff)
downloadaur-641a47e36a03abf7d44340c7a27ea37b324e1090.tar.gz
install udev rules, and remove groups not existent in Arch
Signed-off-by: Gergely Imreh <imrehg@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efd8304debf8..38f896eea6ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=particle-cli
pkgdesc='CLI tool for the Particle hardware platform'
pkgver=1.38.0
-pkgrel=1
+pkgrel=2
arch=(any)
url='http://particle.io/'
license=('GPL')
@@ -17,5 +17,7 @@ sha256sums=('1a23aa99862a072147aca99eaaab9f6ac6596f70e87f5a83a49fa1d75bb4341c')
package() {
npm install -g --user root --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
+ sed -i 's|, GROUP="plugdev"||g; s|, MODE="0666"||g' "${pkgdir}/usr/lib/node_modules/${pkgname}/assets/50-particle.rules"
+ install -D -m644 "${pkgdir}/usr/lib/node_modules/${pkgname}/assets/50-particle.rules" "${pkgdir}/etc/udev/rules.d/50-particle.rules"
rm `find "${pkgdir}/" -name '.deps'` -rf
}