summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Dahl2017-09-24 18:03:01 -0400
committerAlex Dahl2017-09-24 18:03:01 -0400
commita12c5f5bd78b48d6af5e3e73a32aa6e68656aba1 (patch)
tree46609ade7e38ad35903ab7d3883c80d4bf7a6cee /PKGBUILD
parent7f79954561f9b59fa0f7a43c6135e8fdb8edfb40 (diff)
downloadaur-a12c5f5bd78b48d6af5e3e73a32aa6e68656aba1.tar.gz
Updated package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c118171383ad..81ea354e791c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Dahl <adahl1@umbc.edu>
pkgname=partio-git
-pkgver=1.1.0.r73.g7f3e0d1
-pkgrel=4
+pkgver=1.1.0.r91.g2774ef3
+pkgrel=1
pkgdesc="Particle IO and manipulation library (git version)"
arch=(i686 x86_64)
url="http://www.disneyanimation.com/technology/partio.html"
@@ -13,8 +13,8 @@ optdepends=('python2: Python interface support'
makedepends=('cmake>=2.4.6' 'git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/wdas/partio.git' 'CMakeLists.txt.patch' 'py_CMakeLists.txt.patch' 'SeExprv3.patch')
-md5sums=('SKIP' '2f7a6ddc41a5b7d9134820f877b0d2b3' '306cacec7af0af3adb7876c288881062' '92029f98bc024ed5034a299590906f1d')
+source=('git+https://github.com/wdas/partio.git' 'CMakeLists.txt.patch' 'py_CMakeLists.txt.patch')
+md5sums=('SKIP' '74e654e43cf9e9aacd9ac57c0e0e671c' '306cacec7af0af3adb7876c288881062')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -24,8 +24,6 @@ pkgver() {
prepare() {
cd "$srcdir"
- # Path PartioSe for SeExpr v3 until source fixed
- patch -p1 -i "$srcdir/SeExprv3.patch"
# Fix SeExpr dependency and remove tests
patch -p1 -i "$srcdir/CMakeLists.txt.patch"
# Change Python version to 2 to work with SeExpr
@@ -36,7 +34,7 @@ build() {
cd "$srcdir/${pkgname%-git}"
mkdir -p build
cd ./build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev ..
+ cmake -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev ..
make
}