summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorschalox2014-04-21 10:36:11 +0300
committerschalox2014-04-21 10:36:11 +0300
commit5ed0147892fce5ddeb840ae3aaa3a8e21e3dc8bd (patch)
tree0591bf4bbc33e66d4f20dd2e18e35e2423e2cae9 /PKGBUILD
parent0e7042bfe50c8d8bee3bfd968918fa3be539c41b (diff)
downloadaur-5ed0147892fce5ddeb840ae3aaa3a8e21e3dc8bd.tar.gz
20140421.224-1
- FORCE_{BA,F,Z}SHCOMP control whether to install completion files -> no need for Makefile.patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2bbd0fb7584..95e2a6388e46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Simon Zimmermann <simon@insmo.com>
pkgname=pass-git
-pkgver=20140419.220
-pkgrel=2
+pkgver=20140421.224
+pkgrel=1
pkgdesc='Stores, retrieves, generates, and synchronizes passwords securely'
url='http://zx2c4.com/projects/password-store/'
license='GPL2'
@@ -12,10 +12,8 @@ depends=('bash' 'git' 'gnupg' 'grep' 'pwgen' 'tree' 'xclip')
makedepends=('git')
provides=('pass')
conflicts=('pass')
-source=("$pkgname::git://git.zx2c4.com/password-store"
- 'Makefile.patch')
-sha256sums=('SKIP'
- 'be01e83ff15b928b9518e49365587012287533543d68c41c65bcbce78fbeb63c')
+source=("$pkgname::git://git.zx2c4.com/password-store")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -23,11 +21,10 @@ pkgver() {
local _tmpver+="$(git rev-list --count HEAD)"
echo "${_tmpver//-/}"
}
-prepare() {
- cd "$pkgname"
- patch < "${srcdir}/Makefile.patch"
-}
package() {
cd "$pkgname"
- make DESTDIR="${pkgdir}" install
+ make FORCE_BASHCOMP=1 \
+ FORCE_ZSHCOMP=1 \
+ FORCE_FISHCOMP=1 \
+ DESTDIR="${pkgdir}" install
}