summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Pujol2019-09-07 14:40:45 +0100
committerAlexandre Pujol2019-09-07 14:40:45 +0100
commit0392130884d53bcc3ec35e31d441db15eb945ea5 (patch)
tree884182c6246a8f83a4047474636246379c0e8dbc /PKGBUILD
parente1ad0c30c4b0d98883ad12e4569dd705c5b9faa1 (diff)
downloadaur-0392130884d53bcc3ec35e31d441db15eb945ea5.tar.gz
upgpkg: pass-rotate 0.1-2
Cosmetic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3d36682dce8..373da7c5a73f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,25 @@
pkgname='pass-rotate'
pkgver=0.1
-pkgrel=1
-pkgdesc=' A tool and library for rotating your password on online services'
+pkgrel=2
+pkgdesc='A tool and library for rotating your password on online services'
arch=('any')
url='https://github.com/SirCmpwn/pass-rotate'
license=('MIT')
-depends=('python' 'python-beautifulsoup4' 'python-docopt' 'python-requests' 'python-html5lib')
-conflicts=("${pkgname}-git")
-source=(https://github.com/SirCmpwn/${pkgname}/archive/${pkgver}.tar.gz)
+depends=(
+ 'python'
+ 'python-beautifulsoup4'
+ 'python-docopt'
+ 'python-requests'
+ 'python-html5lib'
+)
+makedepends=('python-setuptools')
+conflicts=("$pkgname-git")
+source=(https://github.com/SirCmpwn/$pkgname/archive/$pkgver.tar.gz)
sha512sums=('3c206727439f674cc8eb0429d4adcfca607f3c5187fec7cfee3a7b8e6b461d473955bd68cf159a3f88bb5b6c6e2be5f69f131f187d74ef0228d62817247b4696')
options=(!emptydirs)
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
}