summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Pujol2018-05-09 12:49:53 +0100
committerAlexandre Pujol2018-05-09 12:49:53 +0100
commite1ad0c30c4b0d98883ad12e4569dd705c5b9faa1 (patch)
treee5888f63a48abe3dcc68a3cb4558f6bf5dfd6c6e /PKGBUILD
downloadaur-e1ad0c30c4b0d98883ad12e4569dd705c5b9faa1.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3d36682dce8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Alexandre Pujol <alexandre@pujol.io>
+
+pkgname='pass-rotate'
+pkgver=0.1
+pkgrel=1
+pkgdesc=' A tool and library for rotating your password on online services'
+arch=('any')
+url='https://github.com/SirCmpwn/pass-rotate'
+license=('MIT')
+depends=('python' 'python-beautifulsoup4' 'python-docopt' 'python-requests' 'python-html5lib')
+conflicts=("${pkgname}-git")
+source=(https://github.com/SirCmpwn/${pkgname}/archive/${pkgver}.tar.gz)
+sha512sums=('3c206727439f674cc8eb0429d4adcfca607f3c5187fec7cfee3a7b8e6b461d473955bd68cf159a3f88bb5b6c6e2be5f69f131f187d74ef0228d62817247b4696')
+options=(!emptydirs)
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}