summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAyush Agarwal2021-09-20 00:13:16 +0530
committerAyush Agarwal2021-09-20 00:13:16 +0530
commit33dfb25bee60620181238afed2d101e771188464 (patch)
tree53f7e30ccf0c28b949faa2e4a6a77a9e47fe1be9 /PKGBUILD
downloadaur-33dfb25bee60620181238afed2d101e771188464.tar.gz
added PKGBUILD and .SRCINFO for pass-tessen
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b8a973da041
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Ayush Agarwal <ayush at fastmail dot in>
+
+pkgname=pass-tessen
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="A fuzzy data selection and copying interface for pass"
+arch=(x86_64)
+url="https://github.com/ayushnix/pass-tessen"
+license=('GPL')
+depends=('pass'
+ 'fzf')
+optdepends=('wl-clipboard: to copy text in wayland'
+ 'wl-clipboard-rs: to copy text in wayland'
+ 'xclip: to copy text in xorg')
+conflicts=('pass-tessen-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ayushnix/pass-tessen/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('2b0afe22e6f84d33076b51ad7294b8f77ecc758ed3842db9c0e6a18e2aa711e1')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" install
+}