summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Pujol2018-12-11 22:36:14 +0000
committerAlexandre Pujol2018-12-11 22:36:14 +0000
commit98a31b4b28ec28b59e5e116afc371a39f4baf0a2 (patch)
tree262b55c1a1abf1ae6976e2909147ff349e8b8985 /PKGBUILD
parent3a07e875ef988a2956f25b48d5a654acc8a67a07 (diff)
downloadaur-98a31b4b28ec28b59e5e116afc371a39f4baf0a2.tar.gz
pass-update 2.1 & add check function.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea547120559c..1a7f1e239c68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
# Maintainer: Alexandre Pujol <alexandre@pujol.io>
pkgname='pass-update'
-pkgver=2.0
-pkgrel=2
+pkgver=2.1
+pkgrel=1
pkgdesc='A pass extension that provides an easy flow for updating passwords.'
arch=('any')
url='https://github.com/roddhjav/pass-update'
license=('GPL3')
depends=('pass')
source=(https://github.com/roddhjav/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
- https://github.com/roddhjav/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.sig)
-sha512sums=('b13b8ba50850882df9ea67b9b5ee1f8d1012fd19d92a210a69f49e03a13cee44c01a43069662eb1af2e02df65d7711a9e7238b224dd8c1612e099e6b78768559'
- 'SKIP')
+ https://github.com/roddhjav/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.asc)
+sha512sums=('6f7e12ff8bc608bbfb5ae15efd13052896f247d53d9d092f1c1cc527a0e33d8f638264af2ca4af8c94d772c998f9d321cfceeaaad843fb8b5322a2e9bf7d08d5'
+ '0e58890a2e661080e5e7248a6e3497a2558db14af3a695377c923aeca43bde361d6bafa88ebc35c9a132dfdacb167df76f7fcf1016e51a589baad7c37b32f96d')
# The public key is found at https://pujol.io/keys
# gpg --recv-keys 06A26D531D56C42D66805049C5469996F0DF68EC
validpgpkeys=('06A26D531D56C42D66805049C5469996F0DF68EC')
+check() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ make tests
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver/"
make DESTDIR="$pkgdir" FORCE_ALL=1 install