summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHexhu2020-09-30 23:35:20 -0700
committerHexhu2020-09-30 23:35:20 -0700
commitb9470bfd5cb3d13c96f7237db569873c9ec49807 (patch)
treeea5b4c0e6ed72aea3d2b61ec60014406414f2c92 /PKGBUILD
parent0137928d3d99ec270dd388ba5ff1d0e851081d8f (diff)
downloadaur-b9470bfd5cb3d13c96f7237db569873c9ec49807.tar.gz
systemd unit for passivedns
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e3da3e544a4..d7afd3282e2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,18 @@
_pkgname=passivedns
pkgname=${_pkgname}-git
pkgver=r283.3f387d0
-pkgrel=1
+pkgrel=2
pkgdesc="A network sniffer that logs all DNS server replies for use in a passive DNS setup"
arch=('x86_64')
url="https://github.com/gamelinux/passivedns"
license=('GPLv2')
depends=('ldns' 'libpcap')
-makedepends=('git' 'binutils')
+makedepends=('git' 'binutils')
provides=("${_pkgname}")
-source=("passivedns::git+git://github.com/gamelinux/passivedns.git")
-sha256sums=('SKIP')
+source=("passivedns::git+git://github.com/gamelinux/passivedns.git"
+ passivedns.service)
+sha256sums=('SKIP'
+ '49eccbd5e9f5a78d444abd5b0282af3143de5a4c8105203a3270724685a47a73')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -29,4 +31,6 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
+
+ install -Dm644 ../passivedns.service "$pkgdir"/usr/lib/systemd/system/passivedns.service
}