summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-10-07 23:32:51 +0300
committerorhun2020-10-07 23:32:51 +0300
commit0b851c32174c519aa851316a5aaaea9a937ae17b (patch)
tree8eb0d0874e1e557d77a541c7afafa8e74447c54b /PKGBUILD
parent6645e20c44099598d350f125feef88d2435dee4b (diff)
downloadaur-0b851c32174c519aa851316a5aaaea9a937ae17b.tar.gz
upgpkg: passwall-server-git 1.1.2.r8.ga5bd93b-1
Remove
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80a35257ed99..5f789271531a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,12 +14,12 @@ source=("git+$url")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}/cmd/${pkgname%-git}"
+ cd "${pkgname%-git}/cmd/${pkgname%-git}"
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}/cmd/${pkgname%-git}"
+ cd "${pkgname%-git}/cmd/${pkgname%-git}"
go get -d ./...
go build \
-gcflags "all=-trimpath=$PWD" \
@@ -29,7 +29,7 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}/cmd/${pkgname%-git}"
+ cd "${pkgname%-git}/cmd/${pkgname%-git}"
install -Dm 755 "${pkgname%-git}" "$pkgdir/usr/local/bin/${pkgname%-git}"
install -Dm 644 "../../README.md" -t "$pkgdir/usr/share/doc/${pkgname%-git}"
}