summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Schnaidt2020-01-08 21:06:53 +0100
committerAlexander Schnaidt2020-01-08 21:06:53 +0100
commit650fe1501bd5a89610a9037e040c2edb6bcb7556 (patch)
tree3efccb01c05aa18380c0dee8031096eb06c3d846 /PKGBUILD
parenta6a0c87a2745f8b66954dda06429a05432b1570c (diff)
downloadaur-650fe1501bd5a89610a9037e040c2edb6bcb7556.tar.gz
passwordsafe: update for 1.09.0; drop beta label; add new 'file'/libmagic.so dep; disable gtest
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa6489123344..bdea82ab726a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,28 @@
_pkgname=pwsafe
pkgname=passwordsafe
-_pkgver=1.08.2
-pkgver="$_pkgver"BETA
-pkgrel=2
+pkgver=1.09.0
+pkgrel=1
pkgdesc="Simple & Secure Password Management"
arch=('i686' 'x86_64')
url="https://pwsafe.org/"
license=('Artistic2.0')
-depends=('libxtst' 'wxgtk2' 'yubikey-personalization' 'xerces-c' 'qrencode')
-makedepends=('zip' 'libxt' 'cmake' 'gtest' 'git')
+depends=('libxtst' 'wxgtk2' 'yubikey-personalization' 'xerces-c' 'qrencode' 'file')
+makedepends=('zip' 'libxt' 'cmake' 'git')
optdepends=('xvkbd: virtual-keyboard support')
conflicts=('passwordsafe-debian' 'pwsafe' 'pwsafe-gui')
-source=(https://github.com/pwsafe/pwsafe/archive/$pkgver.tar.gz
- https://github.com/pwsafe/pwsafe/releases/download/$pkgver/$pkgver.tar.gz.sig
- 412458d281-glibc2.30-fix.patch)
+source=(passwordsafe-$pkgver.tar.gz::https://github.com/pwsafe/pwsafe/archive/$pkgver.tar.gz
+ passwordsafe-$pkgver.tar.gz.sig::https://github.com/pwsafe/pwsafe/releases/download/$pkgver/$pkgver.tar.gz.sig)
validpgpkeys=('C8876BE69A8EC6414C8C8729B131423D7F2F1BB9') # http://pgp.mit.edu/pks/lookup?op=vindex&search=0xB131423D7F2F1BB9
-sha1sums=('0643f708517302a715a68241f90072dcb41a0c46'
- 'SKIP'
- '6d7c571d9f03f4f56fd60f8756d2db46e0e334b7')
-
-prepare() {
- cd $_pkgname-$pkgver
- patch -p1 < ../412458d281-glibc2.30-fix.patch
-}
+sha1sums=('9003563367f416d4107cd5e2d41ba37afa6c61a0'
+ 'SKIP')
build() {
cd $_pkgname-$pkgver
mkdir -p build
cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake .. -DNO_GTEST=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
make