summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Schnaidt2019-11-07 13:19:46 +0100
committerAlexander Schnaidt2019-11-07 13:19:46 +0100
commita6a0c87a2745f8b66954dda06429a05432b1570c (patch)
tree6b7fb0bd5aa067abb1ef1fa261d1beee3f5a90a6 /PKGBUILD
parent30685d03c99db147e8f65f4fac9a7fb365317f8e (diff)
downloadaur-a6a0c87a2745f8b66954dda06429a05432b1570c.tar.gz
passwordsafe: glibc2.30 patch; remove leftover passwordsafe-git conflict
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6beeb0990dd2..fa6489123344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=pwsafe
pkgname=passwordsafe
_pkgver=1.08.2
pkgver="$_pkgver"BETA
-pkgrel=1
+pkgrel=2
pkgdesc="Simple & Secure Password Management"
arch=('i686' 'x86_64')
url="https://pwsafe.org/"
@@ -12,12 +12,19 @@ license=('Artistic2.0')
depends=('libxtst' 'wxgtk2' 'yubikey-personalization' 'xerces-c' 'qrencode')
makedepends=('zip' 'libxt' 'cmake' 'gtest' 'git')
optdepends=('xvkbd: virtual-keyboard support')
-conflicts=('passwordsafe-debian' 'passwordsafe-git' 'pwsafe' 'pwsafe-gui')
+conflicts=('passwordsafe-debian' 'pwsafe' 'pwsafe-gui')
source=(https://github.com/pwsafe/pwsafe/archive/$pkgver.tar.gz
- https://github.com/pwsafe/pwsafe/releases/download/$pkgver/$pkgver.tar.gz.sig)
+ https://github.com/pwsafe/pwsafe/releases/download/$pkgver/$pkgver.tar.gz.sig
+ 412458d281-glibc2.30-fix.patch)
validpgpkeys=('C8876BE69A8EC6414C8C8729B131423D7F2F1BB9') # http://pgp.mit.edu/pks/lookup?op=vindex&search=0xB131423D7F2F1BB9
sha1sums=('0643f708517302a715a68241f90072dcb41a0c46'
- 'SKIP')
+ 'SKIP'
+ '6d7c571d9f03f4f56fd60f8756d2db46e0e334b7')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -p1 < ../412458d281-glibc2.30-fix.patch
+}
build() {
cd $_pkgname-$pkgver