diff options
author | Alexander Schnaidt | 2017-05-16 16:31:42 +0200 |
---|---|---|
committer | Alexander Schnaidt | 2017-05-16 17:24:54 +0200 |
commit | b1dff86947390cf567387d8d16958def902446ba (patch) | |
tree | 2b9a2eb49fbf2aee7cdbdab8f9c5347c31147e73 /PKGBUILD | |
parent | e62d2219cc041b18396a359549afca64bed4eaad (diff) | |
download | aur-b1dff86947390cf567387d8d16958def902446ba.tar.gz |
passwordsafe: switch to cmake
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 50 |
1 files changed, 12 insertions, 38 deletions
@@ -2,60 +2,34 @@ _pkgname=pwsafe pkgname=passwordsafe -_pkgver=1.01 +_pkgver=1.02 pkgver="$_pkgver"BETA pkgrel=1 pkgdesc="Simple & Secure Password Management" arch=('i686' 'x86_64') url="https://pwsafe.org/" license=('Artistic2.0') -#to build without yubikey support, remove ykpers and uncomment NO_YUBI in build() +#to build without yubikey support, remove yubikey-personalization and uncomment NO_YUBI in build() depends=('libxtst' 'wxgtk' 'webkitgtk2' 'yubikey-personalization' 'xerces-c') -makedepends=('zip' 'libxt') +makedepends=('zip' 'libxt' 'git' 'cmake') optdepends=('xvkbd: virtual-keyboard support') conflicts=('passwordsafe-debian' 'passwordsafe-git' 'pwsafe' 'pwsafe-gui') source=(https://github.com/pwsafe/pwsafe/archive/$pkgver.tar.gz https://github.com/pwsafe/pwsafe/releases/download/$pkgver/$pkgver.tar.gz.sig) -validpgpkeys=('A703C1328EABC7B201753BA3919464515CCF8BB3') #Rony Shapiro -sha1sums=('46e8c172de272f733c4703adf7bc04ad1a7943f4' +validpgpkeys=('C8876BE69A8EC6414C8C8729B131423D7F2F1BB9') # http://pgp.mit.edu/pks/lookup?op=vindex&search=0xB131423D7F2F1BB9 +sha1sums=('e2e4b31684b0eee39953cf8abbe88262932e09a8' 'SKIP') -prepare() { - cd "$_pkgname-$pkgver" -} - build() { - cd "$_pkgname-$pkgver" -# NO_YUBI=1 \ - WX_CONFIG="/usr/bin/wx-config" \ - make release help I18N + cd $_pkgname-$pkgver + mkdir -p build + cd build + cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release + make } package() { cd "$_pkgname-$pkgver" - - install -Dm 755 src/ui/wxWidgets/GCCUnicodeRelease/pwsafe \ - "$pkgdir"/usr/bin/pwsafe - install -Dm 644 install/desktop/fedora-pwsafe.desktop \ - "$pkgdir"/usr/share/applications/pwsafe.desktop - install -Dm 644 install/graphics/pwsafe.png \ - "$pkgdir"/usr/share/icons/hicolor/48x48/apps/pwsafe.png - - for doc in README.txt docs/ReleaseNotes.txt docs/ChangeLog.txt install/copyright; do - install -Dm 644 "$doc" "$pkgdir"/usr/share/doc/passwordsafe/"$doc" - done - - install -Dm 644 help/helpEN.zip "$pkgdir"/usr/share/doc/passwordsafe/help/helpEN.zip - install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE - install -Dm 644 docs/pwsafe.1 "$pkgdir"/usr/share/man/man1/pwsafe.1 - - install -d 755 "$pkgdir"/usr/share/pwsafe/xml - install -m 644 xml/* "$pkgdir"/usr/share/pwsafe/xml - - cd src/ui/wxWidgets/I18N/mos/ - for lang in *; do - install -Dm 644 "$lang"/LC_MESSAGES/pwsafe.mo \ - "$pkgdir"/usr/share/locale/"$lang"/LC_MESSAGES/pwsafe.mo - done + cd build + DESTDIR="$pkgdir" make install } - |