summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIsmaël Bouya2019-02-14 12:05:42 +0100
committerIsmaël Bouya2019-02-14 12:05:42 +0100
commit77539a71a7ae2deaa736d497a5bd8d60061367ac (patch)
tree513698afbcc46a9fb108e89dee703fb0850c1135 /PKGBUILD
parent7a211847213376f1580e00471e161cc7f1da3c65 (diff)
downloadaur-77539a71a7ae2deaa736d497a5bd8d60061367ac.tar.gz
Add missing pkgver computation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ded3b6c6fa43..b63d00569513 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Immae <ismael.bouya@normalesup.org>
pkgname=patacrep-git
-pkgver=20150614
+pkgver=v5.1.2.r17.g30eb8d62
pkgrel=1
pkgdesc="Engine for LaTeX songbooks"
arch=('any')
@@ -11,16 +11,21 @@ depends=('python' 'python-ply' 'python-jinja' 'python-chardet'
'python-unidecode' 'texlive-fontsextra' 'texlive-latexextra'
'python-argparse' 'lilypond')
makedepends=('python-setuptools')
-source=("patacrep::git://github.com/patacrep/patacrep.git#branch=master")
-sha256sums=(SKIP)
+source=("patacrep-git::git://github.com/patacrep/patacrep.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd "$srcdir/patacrep"
+ cd "$srcdir/$pkgname"
python setup.py build
}
package(){
- cd "$srcdir/patacrep"
+ cd "$srcdir/$pkgname"
python setup.py install --root="${pkgdir}"
}