summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2024-05-14 23:19:08 +0200
committerChristopher Arndt2024-05-14 23:19:08 +0200
commit30da62bd3decd13a732497e3da6c56806caaa7a1 (patch)
tree6d7c4d0d8814585995b198295cfba4fdd5c8be46 /PKGBUILD
parentcb28e0c88777ef67b02a349c72cefe532794fddb (diff)
downloadaur-30da62bd3decd13a732497e3da6c56806caaa7a1.tar.gz
Add patch to disable ALSA support, preventing segfault at start
Change license to SPDX identifier
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0503c9d53141..ebb57001cdfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,23 @@
_pkgname=patchance
pkgname="$_pkgname-git"
-pkgver=0.2.3.r2.ga2e8c61
+pkgver=1.1.0.r6.g9d279f4
pkgrel=1
pkgdesc='A modern graphical patchbay for JACK (git version)'
arch=(any)
url='https://github.com/Houston4444/Patchance'
-license=(GPL2)
-depends=(hicolor-icon-theme python-pyqt5)
+license=(GPL-2.0-only)
+depends=(hicolor-icon-theme python-pyalsa python-pyqt5)
makedepends=(git qt5-tools)
groups=(pro-audio)
provides=($_pkgname)
conflicts=($_pkgname)
source=("$_pkgname::git+https://github.com/Houston4444/Patchance.git"
- 'HoustonPatchbay::git+https://github.com/Houston4444/HoustonPatchbay.git')
+ 'HoustonPatchbay::git+https://github.com/Houston4444/HoustonPatchbay.git'
+ 'patchance-disable-alsa.patch')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'f6efe60272b10759f2dcbd3676e4bc1cdaaafad5e22bf5a0da554260c24ace59')
pkgver() {
cd $_pkgname
@@ -32,6 +34,8 @@ prepare() {
git submodule init
git config submodule.HoustonPatchbay.url "$srcdir"/HoustonPatchbay
git -c protocol.file.allow=always submodule update
+
+ patch -p1 -N -r - -i "$srcdir"/patchance-disable-alsa.patch
}
build() {