summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Bundy2018-08-06 16:02:39 -0700
committerChristian Bundy2018-08-06 16:02:39 -0700
commit20d0caeb7e3592b87dc588be80f016452f684d2f (patch)
tree86cf617341f0e7a8bfbb1fe9880071a4ebdbfe5a /PKGBUILD
parent1206b4e09163c5c2497fba1aa782d45210e77169 (diff)
downloadaur-20d0caeb7e3592b87dc588be80f016452f684d2f.tar.gz
Depend on system Electron
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dec0f7079b95..9bffa169a9b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/ssbc/patchbay"
license=('MIT')
provides=('patchbay')
conflicts=('patchbay')
-depends=('libsodium' 'gtk2' 'gconf' 'python')
+depends=('libsodium' 'gtk2' 'gconf' 'python' 'electron')
makedepends=('nodejs' 'npm' 'git')
options=(!strip)
_srcname=patchbay
@@ -20,7 +20,7 @@ source=(
)
md5sums=('SKIP'
- '6632351cad7b33d94834e9a37f77f727'
+ '1f9644b6941ee0dbd55e4cda6a69604e'
'f459479fef0987c5fa81a38b04767ffa')
pkgver() {
@@ -30,7 +30,7 @@ pkgver() {
build() {
cd "${srcdir}/${_srcname}"
- npm ci
+ npm ci --only=production
npm run rebuild
}