summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2019-10-21 22:40:34 +0200
committerNarrat2019-10-21 22:40:34 +0200
commit9c7640e5128469a4f2d8adbf88230699e41a2320 (patch)
tree7f98da3a550cb987470f5488f6dd44f90d5daa06 /PKGBUILD
parente122ff5ec120fc16c21d258f46168cfbd29084dc (diff)
downloadaur-9c7640e5128469a4f2d8adbf88230699e41a2320.tar.gz
patool: Switch download source
There seems to be a problem with a pre existing egg-info directory with wrong permissions. See the comments from bmwinger for more details. Changed the download to the github source. Another possibility would be to remove in prepare() the directory from the pypi archive.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c3c678ef986..d8e7af929927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=patool
pkgname=('patool' 'patool-py2')
pkgver=1.12
-pkgrel=3
+pkgrel=4
pkgdesc="portable command line archive file manager"
arch=('any')
url="https://wummel.github.io/patool/"
@@ -13,16 +13,16 @@ makedepends=('python-setuptools' 'python2-setuptools')
optdepends=("tar: extracting TAR files"
"unrar: extracting RAR files"
"p7zip: extracting ZIP and 7z files")
-source=("https://pypi.python.org/packages/source/p/$pkgbase/$pkgbase-$pkgver.tar.gz")
-sha256sums=('e3180cf8bfe13bedbcf6f5628452fca0c2c84a3b5ae8c2d3f55720ea04cb1097')
+#source=("https://pypi.python.org/packages/source/p/$pkgbase/$pkgbase-$pkgver.tar.gz")
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/wummel/patool/archive/upstream/1.12.tar.gz")
+sha256sums=('582fd4b87c263325958c1550400504799018c88bc3444f249bba304ae1747f1f')
package_patool() {
pkgdesc+=" (Python3)"
depends=('python')
- cd "$srcdir/${pkgbase}-${pkgver}"
-
+ cd "${pkgbase}-upstream-${pkgver}"
python setup.py install --root=$pkgdir --prefix=/usr --optimize=1
}
@@ -31,7 +31,6 @@ package_patool-py2() {
depends=('python2')
conflicts=('patool')
- cd "$srcdir/${pkgbase}-${pkgver}"
-
+ cd "${pkgbase}-upstream-${pkgver}"
python2 setup.py install --root=$pkgdir --prefix=/usr --optimize=1
}