summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhalosghost2015-07-14 17:55:44 -0500
committerhalosghost2015-07-14 17:55:44 -0500
commitbbc9ba1e0fe817b5cf16926e6e4ed6f75216df12 (patch)
tree8578a32b9f6eaae18065ec9675faeaaf50040aa3 /PKGBUILD
downloadaur-bbc9ba1e0fe817b5cf16926e6e4ed6f75216df12.tar.gz
Name change!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0c355702dea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+
+pkgname=pbpst-git
+pkgver=0.r77.d2c79f1
+pkgrel=1
+
+pkgdesc='A small tool to interact with pb instances'
+url='https://github.com/HalosGhost/pbpst'
+arch=('i686' 'x86_64')
+license=('GPL2')
+
+depends=('curl')
+makedepends=('git' 'tup' 'clang' 'python-sphinx')
+
+source=('git+https://github.com/HalosGhost/pbpst.git')
+sha256sums=('SKIP')
+
+pkgver () {
+ cd pbpst
+ printf '0.r%s.%s' "$(git rev-list --count HEAD)" "$(git log -1 --pretty=format:%h)"
+}
+
+build () {
+ cd pbpst
+ tup upd
+}
+
+package () {
+ cd pbpst
+ install -Dm755 src/pbpst "$pkgdir"/usr/bin/pbpst
+ install -Dm644 doc/pbpst.1 "${pkgdir}"/usr/share/man/man1/pbpst.1
+}