summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaptiste Jonglez2015-06-25 14:35:00 +0200
committerBaptiste Jonglez2015-06-25 14:35:00 +0200
commit77143f2302e994173258e2599dee506ccbd91d2e (patch)
treee7cfe7a6a62c4289832fe0742d49f6932ec01691 /PKGBUILD
downloadaur-77143f2302e994173258e2599dee506ccbd91d2e.tar.gz
Initial upload: pcal 4.11.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40467ec45a63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+# Contributor: Christoph Siegenthaler <csi@gmx.ch>
+pkgname=pcal
+pkgver=4.11.0
+pkgrel=3
+pkgdesc="Pcal is a calendar-generation program which produces nice-looking PostScript output"
+url="http://pcal.sourceforge.net/"
+license=('unknown')
+arch=('i686' 'x86_64')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tgz")
+md5sums=('0ed7e9bec81fe3bdd62f8af283bef704')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Note the usage of $PACK, because the Makefile uses "compress" by
+ # default, which doesn't exist on Arch. Besides, makepkg handles
+ # manpage compression itself.
+ make \
+ PACK=":" \
+ DESTDIR="${pkgdir}" \
+ BINDIR="/usr/bin" \
+ MANDIR="/usr/share/man/man1" \
+ CATDIR="/usr/share/man/cat1" \
+ install
+}