summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNícolas F. R. A. Prado2021-02-26 20:56:30 -0300
committerNícolas F. R. A. Prado2021-02-26 20:56:30 -0300
commit3a0afeaef8fe7161ce47a6a23e8b906da0faf5a2 (patch)
treed632be9dc9d0ea792ac207f271935537cf57a593 /PKGBUILD
downloadaur-3a0afeaef8fe7161ce47a6a23e8b906da0faf5a2.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4847f603b274
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nícolas F. R. A. Prado <nfraprado at protonmail dot com>
+pkgname=pcmn-git
+pkgver=v1.0.0.r0.1a525de0c29e
+pkgrel=1
+pkgdesc="Simple declarative package management for Arch Linux"
+arch=('any')
+url="https://gitlab.com/nfraprado/pcmn"
+license=('GPL3')
+depends=('pacman' 'python' 'yay')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('pcmn::git+https://gitlab.com/nfraprado/pcmn.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 pcmn.py "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm755 config.json "${pkgdir}/usr/share/${pkgname%-git}/config.json"
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+ install -Dm755 README.rst "${pkgdir}/usr/share/doc/${pkgname%-git}/README.rst"
+}