summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralgebro2021-12-24 16:54:11 -0500
committeralgebro2021-12-24 16:54:11 -0500
commit2e7204067bf207538f573bb1972109bbe17c9bbb (patch)
tree1b059a2450472a27c2b1930d5481abff6612e278 /PKGBUILD
parent5dff250aaddd316cc72fcfa912f2f36b60bdfdaa (diff)
downloadaur-2e7204067bf207538f573bb1972109bbe17c9bbb.tar.gz
add capstone
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72c97cf1a08e..05934b184d2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pcsx-redux-git
_pkgname=pcsx-redux
-pkgver=r2245.181779c6
+pkgver=r2659.24046fc2
pkgrel=1
pkgdesc='Modern fork of the pcsxr PlayStation 1 emulator focused on reverse engineering and homebrew development'
arch=('x86_64')
@@ -39,8 +39,9 @@ source=("${_pkgname}::git+https://github.com/grumpycoders/pcsx-redux.git"
'git+https://github.com/Distrotech/ucl.git'
'git+https://github.com/gabomdq/SDL_GameControllerDB'
'git+https://github.com/herumi/xbyak'
- 'git+https://github.com/nicolasnoble/zep'
+ 'git+https://github.com/grumpycoders/zep'
'git+https://github.com/mackron/miniaudio.git'
+ 'git+https://github.com/capstone-engine/capstone.git'
'pcsx-redux.sh'
)
sha256sums=('SKIP'
@@ -64,6 +65,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'21db8ce528f3240388d55d1f309ebc6060bb1145cce50553659e73fb6f89d326')
pkgver() {
@@ -93,6 +95,7 @@ prepare() {
git config submodule.third_party/xbyak.url "$srcdir/xbyak"
git config submodule.third_party/zep.url "$srcdir/zep"
git config submodule.third_party/miniaudio.url "$srcdir/miniaudio"
+ git config submodule.third_party/capstone.url "$srcdir/capstone"
git submodule update third_party/imgui \
third_party/imgui_club \
@@ -112,7 +115,8 @@ prepare() {
third_party/SDL_GameControllerDB \
third_party/xbyak \
third_party/zep \
- third_party/miniaudio
+ third_party/miniaudio \
+ third_party/capstone
cd third_party/luv
git submodule init