summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralgebro2021-03-01 11:44:42 -0500
committeralgebro2021-03-01 11:44:42 -0500
commit5c307bf5f96c4e8aeff337b199fbb6842915b0a3 (patch)
treed95104d7a12d567fd5036670cb7a2b2b4f44323d /PKGBUILD
parentb377db0ca3b863e094c7ebda9ffd7322deb1ae67 (diff)
downloadaur-5c307bf5f96c4e8aeff337b199fbb6842915b0a3.tar.gz
add stb dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 851d47deaec8..434d60ccc78e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pcsx-redux-git
_pkgname=pcsx-redux
-pkgver=r1565.a3b9594
+pkgver=r1572.5917a96
pkgrel=1
pkgdesc='Modern fork of the pcsxr PlayStation 1 emulator focused on reverse engineering and homebrew development'
arch=('x86_64')
@@ -35,6 +35,7 @@ source=("${_pkgname}::git+https://github.com/grumpycoders/pcsx-redux.git"
'git+https://github.com/grumpycoders/LuaJIT.git'
'git+https://github.com/luvit/luv.git'
'git+https://github.com/keplerproject/lua-compat-5.3.git'
+ 'git+https://github.com/nothings/stb.git'
'pcsx-redux.sh'
'pcsx-redux.desktop'
)
@@ -53,6 +54,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'21db8ce528f3240388d55d1f309ebc6060bb1145cce50553659e73fb6f89d326'
'9061d4428ba69e06e3a540df6700a637cc28e740f95b07ca46f2cbcc8cdd347c')
@@ -77,6 +79,7 @@ prepare() {
git config submodule.third_party/libcester.url "$srcdir/libcester"
git config submodule.third_party/luajit.url "$srcdir/LuaJIT"
git config submodule.third_party/luv.url "$srcdir/luv"
+ git config submodule.third_party/stb.url "$srcdir/stb"
git submodule update third_party/imgui \
third_party/imgui_club \
@@ -90,7 +93,8 @@ prepare() {
third_party/ELFIO \
third_party/libcester \
third_party/luajit \
- third_party/luv
+ third_party/luv \
+ third_party/stb
cd third_party/luv
git submodule init