summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralgebro2021-02-26 16:20:05 -0500
committeralgebro2021-02-26 16:20:05 -0500
commit7fe91e2476436a498161515471f96506f8c1f744 (patch)
treefdc30955214075ccb36d30699ee3de10c2a80e06 /PKGBUILD
parent0e956a715884128b632c8acc3a0f0eafaee585bf (diff)
downloadaur-7fe91e2476436a498161515471f96506f8c1f744.tar.gz
Switch to recursive submodule update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 2 insertions, 47 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91166c956356..212893ebd0cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pcsx-redux-git
_pkgname=pcsx-redux
-pkgver=r1272.6c73f79
+pkgver=r1542.110c5bf
pkgrel=1
pkgdesc='Modern fork of the pcsxr PlayStation 1 emulator focused on reverse engineering and homebrew development'
arch=('x86_64')
@@ -20,32 +20,10 @@ makedepends=('clang'
'pkg-config'
)
source=("${_pkgname}::git+https://github.com/grumpycoders/pcsx-redux.git"
- 'git+https://github.com/ocornut/imgui.git'
- 'git+https://github.com/ocornut/imgui_club.git'
- 'git+https://github.com/grumpycoders/ImGuiColorTextEdit.git'
- 'git+https://github.com/mateidavid/zstr.git'
- 'git+https://github.com/grumpycoders/uC-sdk.git'
- 'git+https://github.com/google/googletest.git'
- 'git+https://github.com/fmtlib/fmt.git'
- 'git+https://github.com/skypjack/uvw.git'
- 'git+https://github.com/nodejs/http-parser.git'
- 'git+https://github.com/serge1/ELFIO.git'
- 'git+https://github.com/exoticlibraries/libcester.git'
'pcsx-redux.sh'
'pcsx-redux.desktop'
)
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'21db8ce528f3240388d55d1f309ebc6060bb1145cce50553659e73fb6f89d326'
'9061d4428ba69e06e3a540df6700a637cc28e740f95b07ca46f2cbcc8cdd347c')
@@ -56,30 +34,7 @@ pkgver() {
prepare() {
cd "$_pkgname"
- git submodule init
- git config submodule.third_party/imgui.url "$srcdir/imgui"
- git config submodule.third_party/imgui_club.url "$srcdir/imgui_club"
- git config submodule.third_party/ImGuiColorTextEdit.url "$srcdir/ImGuiColorTextEdit"
- git config submodule.third_party/zstr.url "$srcdir/zstr"
- git config submodule.third_party/uC-sdk.url "$srcdir/uC-sdk"
- git config submodule.third_party/googletest.url "$srcdir/googletest"
- git config submodule.third_party/fmt.url "$srcdir/fmt"
- git config submodule.third_party/uvw.url "$srcdir/uvw"
- git config submodule.third_party/http-parser.url "$srcdir/http-parser"
- git config submodule.third_party/ELFIO.url "$srcdir/ELFIO"
- git config submodule.third_party/libcester.url "$srcdir/libcester"
-
- git submodule update third_party/imgui \
- third_party/imgui_club \
- third_party/ImGuiColorTextEdit \
- third_party/zstr \
- third_party/uC-sdk \
- third_party/googletest \
- third_party/fmt \
- third_party/uvw \
- third_party/http-parser \
- third_party/ELFIO \
- third_party/libcester
+ git submodule update --init --recursive
}
build() {