summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralgebro2021-02-27 18:54:18 -0500
committeralgebro2021-02-27 18:54:18 -0500
commitb377db0ca3b863e094c7ebda9ffd7322deb1ae67 (patch)
tree626d5542396a194382f4d790fa893eda318687d2 /PKGBUILD
parent7fe91e2476436a498161515471f96506f8c1f744 (diff)
downloadaur-b377db0ca3b863e094c7ebda9ffd7322deb1ae67.tar.gz
disable buildflags to fix luajit compile error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD72
1 files changed, 67 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 212893ebd0cc..851d47deaec8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pcsx-redux-git
_pkgname=pcsx-redux
-pkgver=r1542.110c5bf
+pkgver=r1565.a3b9594
pkgrel=1
pkgdesc='Modern fork of the pcsxr PlayStation 1 emulator focused on reverse engineering and homebrew development'
arch=('x86_64')
@@ -11,19 +11,48 @@ license=('GPL2')
depends=('ffmpeg'
'glfw-x11'
'libuv'
+ 'freetype2'
'sdl2'
'zlib'
)
-makedepends=('clang'
- 'git'
+options=('!buildflags')
+makedepends=('git'
'make'
'pkg-config'
)
source=("${_pkgname}::git+https://github.com/grumpycoders/pcsx-redux.git"
+ 'git+https://github.com/ocornut/imgui.git'
+ 'git+https://github.com/ocornut/imgui_club.git'
+ 'git+https://github.com/grumpycoders/ImGuiColorTextEdit.git'
+ 'git+https://github.com/mateidavid/zstr.git'
+ 'git+https://github.com/grumpycoders/uC-sdk.git'
+ 'git+https://github.com/google/googletest.git'
+ 'git+https://github.com/fmtlib/fmt.git'
+ 'git+https://github.com/skypjack/uvw.git'
+ 'git+https://github.com/nodejs/http-parser.git'
+ 'git+https://github.com/serge1/ELFIO.git'
+ 'git+https://github.com/exoticlibraries/libcester.git'
+ 'git+https://github.com/grumpycoders/LuaJIT.git'
+ 'git+https://github.com/luvit/luv.git'
+ 'git+https://github.com/keplerproject/lua-compat-5.3.git'
'pcsx-redux.sh'
'pcsx-redux.desktop'
)
sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'21db8ce528f3240388d55d1f309ebc6060bb1145cce50553659e73fb6f89d326'
'9061d4428ba69e06e3a540df6700a637cc28e740f95b07ca46f2cbcc8cdd347c')
@@ -34,12 +63,45 @@ pkgver() {
prepare() {
cd "$_pkgname"
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.third_party/imgui.url "$srcdir/imgui"
+ git config submodule.third_party/imgui_club.url "$srcdir/imgui_club"
+ git config submodule.third_party/ImGuiColorTextEdit.url "$srcdir/ImGuiColorTextEdit"
+ git config submodule.third_party/zstr.url "$srcdir/zstr"
+ git config submodule.third_party/uC-sdk.url "$srcdir/uC-sdk"
+ git config submodule.third_party/googletest.url "$srcdir/googletest"
+ git config submodule.third_party/fmt.url "$srcdir/fmt"
+ git config submodule.third_party/uvw.url "$srcdir/uvw"
+ git config submodule.third_party/http-parser.url "$srcdir/http-parser"
+ git config submodule.third_party/ELFIO.url "$srcdir/ELFIO"
+ git config submodule.third_party/libcester.url "$srcdir/libcester"
+ git config submodule.third_party/luajit.url "$srcdir/LuaJIT"
+ git config submodule.third_party/luv.url "$srcdir/luv"
+
+ git submodule update third_party/imgui \
+ third_party/imgui_club \
+ third_party/ImGuiColorTextEdit \
+ third_party/zstr \
+ third_party/uC-sdk \
+ third_party/googletest \
+ third_party/fmt \
+ third_party/uvw \
+ third_party/http-parser \
+ third_party/ELFIO \
+ third_party/libcester \
+ third_party/luajit \
+ third_party/luv
+
+ cd third_party/luv
+ git submodule init
+ git config submodule.deps/lua-compat-5.3.url "$srcdir/lua-compat-5.3"
+
+ git submodule update deps/lua-compat-5.3
}
build() {
cd "$_pkgname"
- CC=/usr/bin/clang CXX=/usr/bin/clang++ make
+ make
}
package() {