summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralgebro2021-03-07 14:38:04 -0500
committeralgebro2021-03-07 14:38:04 -0500
commitc6583777ffe967b2fe75988772164eaa1506cefa (patch)
tree119a6d7b2ca7e9509b2bd823ec6e00a3e84e7cd0 /PKGBUILD
parentbdd4402ec19b04659f6814cf2a783d4b2e89cdd4 (diff)
downloadaur-c6583777ffe967b2fe75988772164eaa1506cefa.tar.gz
add tracy submodule
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ca48ed2330e..cf46dc81598a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pcsx-redux-git
_pkgname=pcsx-redux
-pkgver=r1586.20a0c00
+pkgver=r1616.d17da13
pkgrel=1
pkgdesc='Modern fork of the pcsxr PlayStation 1 emulator focused on reverse engineering and homebrew development'
arch=('x86_64')
@@ -35,6 +35,7 @@ source=("${_pkgname}::git+https://github.com/grumpycoders/pcsx-redux.git"
'git+https://github.com/luvit/luv.git'
'git+https://github.com/keplerproject/lua-compat-5.3.git'
'git+https://github.com/nothings/stb.git'
+ 'git+https://github.com/wolfpld/tracy.git'
'pcsx-redux.sh'
'pcsx-redux.desktop'
)
@@ -53,6 +54,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'21db8ce528f3240388d55d1f309ebc6060bb1145cce50553659e73fb6f89d326'
'9061d4428ba69e06e3a540df6700a637cc28e740f95b07ca46f2cbcc8cdd347c')
@@ -77,6 +79,7 @@ prepare() {
git config submodule.third_party/luajit.url "$srcdir/LuaJIT"
git config submodule.third_party/luv.url "$srcdir/luv"
git config submodule.third_party/stb.url "$srcdir/stb"
+ git config submodule.third_party/tracy.url "$srcdir/tracy"
git submodule update third_party/imgui \
third_party/imgui_club \
@@ -90,7 +93,8 @@ prepare() {
third_party/libcester \
third_party/luajit \
third_party/luv \
- third_party/stb
+ third_party/stb \
+ third_party/tracy
cd third_party/luv
git submodule init