summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkenshen1122021-11-23 06:06:07 -0700
committerkenshen1122021-11-23 06:06:07 -0700
commit3123f01443ca636b46e356a8e6cf1ed7fda818cd (patch)
treefb95f83124c3e3b1a8166a91b6696fc8e441612f /PKGBUILD
parent48716d695d41fbbf93ca51465dd39981aa484d77 (diff)
downloadaur-3123f01443ca636b46e356a8e6cf1ed7fda818cd.tar.gz
Set PCAP and Disabled cmake from attempting to set it. GameDB : fix Fuuraiki 2 patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a35a300e2178..71ec339fbd02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=1.7.2047
+pkgver=1.7.2075
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -69,12 +69,18 @@ build() {
-DGAMEINDEX_DIR=/usr/share/pcsx2 \
-GNinja \
-DPACKAGE_MODE=ON \
- -DXDG_STD=TRUE
- ninja
+ -DXDG_STD=TRUE \
+ -DDISABLE_SETCAP=ON
+ ninja -j$(nproc)
}
# For DEV9 netplay support
-post()
+post_install()
+{
+ setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' ${pkgdir}
+}
+
+post_upgrade()
{
setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' ${pkgdir}
}