summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkenshen1122022-04-15 19:48:07 -0700
committerkenshen1122022-04-15 19:48:07 -0700
commit46bc5bb8e225dca0e50c242f5854e06d618ad45f (patch)
treea5be49f7868f25166c186705be5abd4b59eaf8a9 /PKGBUILD
parent6de5292a2a0ea039f2ac1c23d913c7431408bd12 (diff)
downloadaur-46bc5bb8e225dca0e50c242f5854e06d618ad45f.tar.gz
ps1 mode cd logic adjustments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff97d956a643..8b00a16e741f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=1.7.2614
+pkgver=1.7.2617
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -52,6 +52,8 @@ git+https://github.com/fmtlib/fmt.git
git+https://github.com/ocornut/imgui.git
git+https://github.com/rtissera/libchdr.git
git+https://github.com/google/googletest.git
+git+https://github.com/nih-at/libzip.git
+git+https://github.com/facebook/zstd.git
git+https://github.com/mozilla/cubeb.git
git+https://github.com/KhronosGroup/glslang.git
git+https://github.com/libsdl-org/SDL.git
@@ -77,6 +79,8 @@ prepare()
git config submodule.https://github.com/ocornut/imgui.git.url imgui
git config submodule.https://github.com/KhronosGroup/glslang.git glslang
git config submodule.https://github.com/libsdl-org/SDL.git SDL
+ git config submodule.https://github.com/nih-at/libzip.git libzip
+ git config submodule.https://github.com/facebook/zstd.git ztsd
git submodule update
}
@@ -86,7 +90,7 @@ build()
cd build
cmake ../pcsx2 \
- -DCMAKE_BUILD_TYPE=Debug \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_SYSTEM_YAML=TRUE \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
@@ -112,4 +116,6 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')