summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkenshen1122022-06-23 14:27:25 -0700
committerkenshen1122022-06-23 14:27:25 -0700
commit4e8a37ac4060fa27862efd2781d763331647f667 (patch)
tree79afca7b02fa8b9a05ae630ab32fb4341fc7733e /PKGBUILD
parent0b6ee0cd5224b4e7f128f12f982e32e69000fa3d (diff)
downloadaur-4e8a37ac4060fa27862efd2781d763331647f667.tar.gz
Improved PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 24 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2534656ecc43..d9fe62137f95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=1.7.2991
+pkgver=1.7.2992
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -49,8 +49,11 @@ makedepends=(
python
vulkan-headers
)
-provides=(pcsx2-qt)
+
+provides=(pcsx2)
+
conflicts=(pcsx2)
+
source=(
git+https://github.com/PCSX2/pcsx2.git
git+https://github.com/ocornut/imgui.git
@@ -60,17 +63,21 @@ git+https://github.com/mozilla/cubeb.git
git+https://github.com/KhronosGroup/glslang.git
git+https://github.com/KhronosGroup/Vulkan-Headers.git
)
-sha256sums=(SKIP)
-pkgver()
-{
- cd pcsx2
- git describe --tags | sed 's/^v//; s/-dev//; s/-/.r/; s/-g/./'
-}
+sha256sums=(
+SKIP
+SKIP
+SKIP
+SKIP
+SKIP
+SKIP
+SKIP
+)
prepare()
{
cd $srcdir/pcsx2
+ git checkout tags/v"${pkgver}"
git submodule init
git config submodule.3rdparty/libchdr/libchdr.url $srcdir/libchdr
git config submodule.3rdparty/gtest.url $srcdir/googletest
@@ -81,6 +88,12 @@ prepare()
git submodule update 3rdparty/libchdr/libchdr 3rdparty/gtest 3rdparty/cubeb/cubeb 3rdparty/imgui 3rdparty/glslang/glslang 3rdparty/vulkan-headers
}
+pkgver()
+{
+ cd $srcdir/pcsx2
+ git describe --tags | sed 's/^v//; s/-dev//; s/-/.r/; s/-g/./'
+}
+
build()
{
mkdir -p build
@@ -105,19 +118,9 @@ package()
{
DESTDIR="${pkgdir}" cmake --install build
mv "${pkgdir}"/usr/bin/pcsx2-qt "${pkgdir}"/usr/share/PCSX2
- ln -s "${pkgdir}"/usr/share/PCSX2/pcsx2-qt "${pkgdir}"/usr/bin/pcsx2-qt
-}
-
-post_install()
-{
- rm /usr/bin/pcsx2
+ ln -s /usr/share/PCSX2/pcsx2-qt "${pkgdir}"/usr/bin/pcsx2-qt
+ sed -i 's/Exec=env GDK_BACKEND=x11 MESA_NO_ERROR=1 pcsx2/Exec=pcsx2-qt/g' "${pkgdir}"/usr/share/applications/PCSX2.desktop
}
# vim: ts=2 sw=2 et:
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+