summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkenshen1122020-11-05 05:26:05 -0700
committerkenshen1122020-11-05 05:26:05 -0700
commit6913fd0f509192a93f2697ae98e2b14c61ba1979 (patch)
tree7bbbb86e4d15a0454745442d2ee12f3341bdc1d8 /PKGBUILD
parentd3b30c21709262b867f703bbca71164389191d78 (diff)
downloadaur-6913fd0f509192a93f2697ae98e2b14c61ba1979.tar.gz
Added fmt submodule, Added a massive amount of commits though my ps1 cd fix was the most recent
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 391d23d6d39a..2b6fd2f354f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=1.7.0.r430.49b92d956
+pkgver=1.7.0.r525.ada804741
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -33,7 +33,8 @@ makedepends=(
)
provides=(pcsx2)
conflicts=(pcsx2)
-source=(git+https://github.com/PCSX2/pcsx2.git)
+source=(git+https://github.com/PCSX2/pcsx2.git
+git+https://github.com/fmtlib/fmt.git)
sha256sums=(SKIP)
pkgver() {
@@ -44,6 +45,14 @@ pkgver() {
build() {
mkdir -p build
+
+ cd $srcdir/pcsx2/3rdparty
+ git submodule init
+ git config submodule.https://github.com/fmtlib/src/fmt.git.url $srcdir/fmt
+ git submodule update
+
+ cd ../..
+
cd build
cmake ../pcsx2 \