summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkenshen1122021-11-23 18:35:14 -0700
committerkenshen1122021-11-23 18:35:14 -0700
commit8efcdabf16fffbc784eda5e528300db6587265f9 (patch)
treec56d951bad0c4b1f590642845441ed134fc06df6 /PKGBUILD
parent3123f01443ca636b46e356a8e6cf1ed7fda818cd (diff)
downloadaur-8efcdabf16fffbc784eda5e528300db6587265f9.tar.gz
Added properish but will probably break on other distros post_install script. GS: Partial revert of #5061
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71ec339fbd02..9c1f76c06bed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=1.7.2075
+pkgver=1.7.2077
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -15,6 +15,8 @@ license=(
LGPL3
)
+install=dev9.install
+
depends=(
libaio
libjpeg-turbo
@@ -41,7 +43,8 @@ git+https://github.com/rtissera/libchdr.git
git+https://github.com/google/googletest.git)
sha256sums=(SKIP)
-pkgver() {
+pkgver()
+{
cd pcsx2
git describe --tags | sed 's/^v//; s/-dev//; s/-/.r/; s/-g/./'
}
@@ -58,7 +61,8 @@ prepare()
}
-build() {
+build()
+{
mkdir -p build
cd build
@@ -74,18 +78,8 @@ build() {
ninja -j$(nproc)
}
-# For DEV9 netplay support
-post_install()
-{
- setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' ${pkgdir}
-}
-
-post_upgrade()
+package()
{
- setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' ${pkgdir}
-}
-
-package() {
DESTDIR="${pkgdir}" cmake --install build
}