summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkenshen1122020-09-01 18:40:27 -0700
committerkenshen1122020-09-01 18:40:27 -0700
commite8a9131e60b30d672cdcdc44d1159bfda38283c6 (patch)
treed6d0a0fb27a11b664e5e948ebeee3a4e9de54010 /PKGBUILD
parente0b5f2ee69246f097c0b93c478918228322541ba (diff)
downloadaur-e8a9131e60b30d672cdcdc44d1159bfda38283c6.tar.gz
Flip to ninja, fix OSD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e33b930cde43..13f221f7af85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
-# Maintainer: rafaelff <rafaelff@gnome.org>
+# Maintainer: rafaelff <rafaelff@gnome.org>, WeirdBeard <obarrtimothy@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Themaister <maister@archlinux.us>
-# Contributor: WeirdBeard <obarrtimothy@gmail.com>
pkgname=pcsx2-git
-pkgver=1.7.0.r188.91326e1d9
+pkgver=1.7.0.r208.4629c8363
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -17,19 +16,20 @@ license=(
)
depends=(
- libaio
- libjpeg-turbo
- libpcap
- libpulse
- portaudio
- sdl2
- soundtouch
- wxgtk2
+ lib32-libaio
+ lib32-libjpeg-turbo
+ lib32-libpcap
+ lib32-libpulse
+ lib32-portaudio
+ lib32-sdl2
+ lib32-soundtouch
+ lib32-wxgtk2
)
makedepends=(
cmake
git
xorgproto
+ ninja
)
provides=(pcsx2)
conflicts=(pcsx2)
@@ -53,13 +53,14 @@ build() {
-DCMAKE_LIBRARY_PATH=/usr/lib32 \
-DPLUGIN_DIR=/usr/lib32/pcsx2 \
-DGAMEINDEX_DIR=/usr/share/pcsx2 \
+ -GNinja \
-DPACKAGE_MODE=ON \
-DXDG_STD=TRUE
- make
+ ninja
}
package() {
- make DESTDIR="$pkgdir" -C build install
+ DESTDIR="${pkgdir}" cmake --install build
}
# vim: ts=2 sw=2 et: