summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2016-08-16 21:25:23 +0200
committerMaxime Gauduin2016-08-16 21:25:23 +0200
commitaf99cb5d41380cbc4231db92512cba1b8690c47d (patch)
tree068adb392ab1281fb4dc5ba0034befb919b7de75 /PKGBUILD
downloadaur-af99cb5d41380cbc4231db92512cba1b8690c47d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..543136f40a1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Infy <eugene.yudin@gmail.com>
+
+pkgname=pcsxr-git
+pkgver=1.9.93.r1662.fc378b6
+pkgrel=1
+pkgdesc='A Sony PlayStation emulator based on the PCSX-df Project'
+arch=('i686' 'x86_64')
+url='http://pcsxr.codeplex.com/'
+license=('GPL')
+depends=('gtk3' 'libarchive' 'libcdio' 'libxv' 'sdl2')
+makedepends=('git' 'intltool' 'mesa')
+[[ $CARCH == i686 ]] && makedepends+=('nasm')
+provides=('pcsxr')
+conflicts=('pcsxr' 'pcsx-df')
+replaces=('pcsxr-svn')
+source=('git+https://git01.codeplex.com/pcsxr')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pcsxr
+
+ echo "1.9.93.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd pcsxr/pcsxr
+
+ chmod +x autogen.sh
+ ./autogen.sh \
+ --prefix='/usr' \
+ --enable-{libcdio,opengl}
+ make
+}
+
+package() {
+ cd pcsxr/pcsxr
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: