summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStelios Tsampas2020-05-20 08:56:01 +0300
committerStelios Tsampas2020-05-20 08:56:01 +0300
commitcec134a96cd945d9e06db42bb953752f9f6ed537 (patch)
tree5b28361be08668f40d3ba6690c013538bc178bea /PKGBUILD
parent45907a7f512c2f82a09297f9007dcd38f9b2bce1 (diff)
downloadaur-cec134a96cd945d9e06db42bb953752f9f6ed537.tar.gz
Use clang until ODR violations are fixes for GCC 10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cc6275a0856..20d59de95051 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=pcsxr-pgxp-git
pkgver=1.9.94.r1731.62467b86
-pkgrel=1
+pkgrel=2
pkgdesc='A Sony PlayStation (PSX) emulator based on the PCSX-df Project with Parallel/Precision Geometry Transform Pipeline'
arch=('x86_64')
url='http://ngemu.com/threads/pcsxr-pgxp.186369/'
license=('GPL')
depends=('ffmpeg' 'gtk3' 'libarchive' 'libcdio' 'libxv')
-makedepends=('cmake' 'git' 'intltool' 'mesa')
+makedepends=('cmake' 'git' 'intltool' 'mesa' 'clang')
provides=('pcsxr' "${pkgname/%-git/}")
conflicts=('pcsxr' "${pkgname/%-git/}")
source=("${pkgname/%-git/}::git+https://github.com/iCatButler/pcsxr.git"
@@ -34,6 +34,9 @@ prepare() {
build() {
cd "${pkgname/%-git/}"/build
+
+ export CC="clang"
+ export CXX="clang++"
cmake .. \
-DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_INSTALL_PREFIX='/usr' \