summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlbert Graef2022-03-23 13:32:16 +0100
committerAlbert Graef2022-03-23 13:32:16 +0100
commit740d00a8ac31eea50a7d0b2437dc7e637fd2be99 (patch)
tree581c186ed5c8cc1f9a2376cd6acfda4b02f8cd0b /PKGBUILD
parentb9e79d330f6f01defda2f3d6d9e045abc5168bac (diff)
downloadaur-740d00a8ac31eea50a7d0b2437dc7e637fd2be99.tar.gz
Fix Faust API breakage.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b757d5d9a61..efa1e729419a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ srcname=pd-faustgen
dstname=$pkgpref-faustgen2
pkgname=$dstname-git
-pkgver=2.0.2.r0.ga02c13a
+pkgver=2.0.2.r8.g9ac1471
pkgrel=1
pkgdesc="The FAUST compiler embedded in a Pd external - git version"
arch=("i686" "x86_64")
@@ -30,8 +30,10 @@ depends=("$puredata" 'llvm-libs')
makedepends=('cmake' 'faust' 'llvm')
provides=("$dstname")
conflicts=("$dstname")
-source=("git+https://github.com/agraef/$srcname.git")
-md5sums=('SKIP')
+source=("git+https://github.com/agraef/$srcname.git"
+ "faust-api-breakage.diff")
+md5sums=('SKIP'
+ 'a9d2cdb5d664a8c9954b1b09fcb7b22f')
pkgver() {
cd "$srcname"
@@ -40,6 +42,11 @@ pkgver() {
prepare() {
cd "$srcname"
+ # Work around recent API breakage in Faust version 2.37.3 and later. This
+ # should really be fixed upstream in pd-faustgen2 using some cmake magic,
+ # but this will do for now. Thanks to Björn Kessler for spotting this and
+ # contributing the patch.
+ patch -p1 -i ../faust-api-breakage.diff
# We don't have to initialize the faust submodules, as we're building
# against an installed libfaust. This makes checking out the submodules
# much quicker.