summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2017-10-25 01:25:22 +0200
committerDavid Runge2017-10-25 01:25:22 +0200
commit5e7088bda08931073843d554d242c9c353b206d2 (patch)
treef74c0eed90facb922240efb416b6ffd07d4bdd5a /PKGBUILD
parent4aa031e1c158731ca27aace0b64752649d0781a7 (diff)
downloadaur-5e7088bda08931073843d554d242c9c353b206d2.tar.gz
PKGBUILD: Switching to https for cloning. Switching to autoreconf from autogen.sh (now in prepare()). Enabling fftw again. Not enabling debugging by default. Cleaning up use of install.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed5070a8fd3d..9f89834da007 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
# Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
pkgname=pd-git
-_name=pd
+_pkg=pd
pkgver=0.48.0.r0.geafd434
-pkgrel=1
+pkgrel=2
pkgdesc="The Pure Data real-time music and multimedia environment"
arch=('i686' 'x86_64')
url="http://msp.ucsd.edu/software.html"
@@ -14,39 +14,41 @@ license=('custom:BSD')
depends=('jack' 'tk' 'fftw')
provides=('pd')
conflicts=('pd')
-options=('!strip' '!buildflags')
-source=("${_name}::git://git.code.sf.net/p/pure-data/pure-data"
- "${_name}.desktop")
+options=('!strip')
+source=("${_pkg}::git+https://git.code.sf.net/p/pure-data/pure-data"
+ "${_pkg}.desktop")
sha512sums=('SKIP'
'4d3596b337456117ecdf0f1709358b4298198e0b347cb13b884e35ad2f2f667561a10b44683cf916c1da123daebee7141e9ab8bd89405a579b69d30b0e718f37')
pkgver() {
- cd ${_name}
+ cd ${_pkg}
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${_pkg}"
+ autoreconf -f -i
+}
+
build() {
- cd ${_name}
- ./autogen.sh
+ cd "${_pkg}"
./configure --prefix=/usr \
--enable-alsa \
--enable-jack \
--disable-portaudio \
- --enable-fftw=no \
- --enable-debug
+ --enable-fftw
make
}
package() {
- cd ${_name}
- make DESTDIR="$pkgdir" install
+ cd "${_pkg}"
+ make DESTDIR="${pkgdir}" install
# license
- install -Dm644 LICENSE.txt \
- "$pkgdir/usr/share/licenses/pd/LICENSE"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${_pkg}/LICENSE"
# desktop file
- install -Dm644 $srcdir/${_name}.desktop \
- $pkgdir/usr/share/applications/${_name}.desktop
+ install -Dm644 "${srcdir}/${_pkg}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkg}.desktop"
}
# vim:set ts=2 sw=2 et: