summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:58:10 +0200
committerAlbert Graef2015-06-13 22:58:10 +0200
commit202bf65e9fc0623a274ee2d68adbb93fcf957841 (patch)
treee80e079bf318a240ad876d05b7fa5164dfc5096f /PKGBUILD
downloadaur-202bf65e9fc0623a274ee2d68adbb93fcf957841.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f46cc89efa8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Albert Graef <aggraef at gmail dot com>
+
+pkgname=pd-lv2plugin-git
+pkgver=14.539522c
+pkgrel=1
+pkgdesc="LV2 plugin host for Pd"
+arch=("i686" "x86_64")
+license=('BSD')
+url="https://bitbucket.org/agraef/pd-lv2plugin/"
+depends=('pd' 'pd-pure' 'pure-lilv')
+makedepends=()
+source=("git+https://bitbucket.org/agraef/pd-lv2plugin")
+md5sums=(SKIP)
+
+pkgver() {
+ cd $srcdir/pd-lv2plugin
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $srcdir/pd-lv2plugin
+ make || return 1
+}
+
+package() {
+ cd $srcdir/pd-lv2plugin
+ make DESTDIR=$pkgdir install || return 1
+}