summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée2016-09-30 13:42:49 +0200
committerMattias Andrée2016-09-30 13:42:49 +0200
commit56af75ba33c880c36d0791d97f2712b54fb7635e (patch)
tree63e4ed94bca596bb65012b57842572b3d92d2697 /PKGBUILD
downloadaur-56af75ba33c880c36d0791d97f2712b54fb7635e.tar.gz
Initial import, version 1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..431bddff6157
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=pdeath
+pkgver=1.0
+pkgrel=1
+pkgdesc="Run a command that is killed when its parent exits"
+arch=(i686 x86_64)
+url="https://github.com/maandree/pdeath"
+license=('custom:ISC')
+depends=(glibc 'linux>=2.1.57')
+makedepends=(glibc 'linux>=2.1.57' make coreutils gcc)
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(e9066459fe4af6e6607f45dc119d1c0030893bfdc5b37e753e952678be468250)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+}
+