summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Schadt2022-05-21 10:58:09 +0200
committerDaniel Schadt2022-05-21 10:58:09 +0200
commitbf06dbd2919ff9bea35bb366ff7857d971661932 (patch)
treef67ded2682dc22c77204ffd728f8f7f050454929 /PKGBUILD
downloadaur-pdfannots-git.tar.gz
Publish first version of package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d42f7e3a30ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Daniel <echo 'a2luZ2RyZWFkQGdteC5kZQo=' | base64 -d>
+
+pkgname=pdfannots-git
+pkgdesc='Extracts and formats text annotations from a PDF file'
+url='https://github.com/0xabu/pdfannots'
+license=('MIT')
+pkgver=0.3.r20.g43b574d
+pkgrel=1
+arch=('any')
+source=("git+https://github.com/0xabu/pdfannots")
+sha256sums=('SKIP')
+makedepends=('python-setuptools' 'git')
+depends=('python-pdfminer')
+
+pkgver() {
+ cd "pdfannots"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "pdfannots"
+ python setup.py build
+}
+
+package() {
+ cd "pdfannots"
+ python setup.py install --root="$pkgdir" --optimize=1
+}