summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzoe2020-04-02 01:06:21 +0200
committerzoe2020-04-02 01:06:21 +0200
commit25846545ce9522969c5e2b818f63ae9c3774ab8b (patch)
tree181e619c80ec90fe2e1bdfe7646de4103117f042 /PKGBUILD
downloadaur-25846545ce9522969c5e2b818f63ae9c3774ab8b.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68e67487d35e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: zoe <chp321 [at] gmail [dot] com>
+
+pkgname=pdfcropmargins
+PkgName=pdfCropMargins
+pkgver=0.2.6
+pkgrel=1
+pkgdesc="Automatically crops the margins of PDF files"
+arch=('any')
+depends=('python-setuptools' 'python-wheel' 'python-pysimplegui' 'python-pymupdf' 'ghostscript' 'poppler')
+url="https://pypi.org/project/pdfCropMargins/"
+license=('GPL')
+source=("https://files.pythonhosted.org/packages/c2/33/622baca4910c48c9d4b29d804b4690389dff6b0d6730d31a7b4d9ed9fd66/$PkgName-$pkgver.tar.gz")
+md5sums=('ec662f0d5ebc99a9d97a63526fefbbfd')
+
+build() {
+ cd $srcdir/$PkgName-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$PkgName-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}