summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlamus Diu2018-06-18 20:37:26 +0000
committerFlamus Diu2018-06-18 20:37:26 +0000
commit505b0adec4cd775edad09e9ff312e8ff93767cd2 (patch)
treee64ce2417661a3acf8213103255736f3e558c85f /PKGBUILD
parentdf4e7ef1a1c4e342df8bce08d1a82538f8b0f4e0 (diff)
downloadaur-505b0adec4cd775edad09e9ff312e8ff93767cd2.tar.gz
Upgraded to PDFStudio v18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 919986e7885d..e8cc3b376438 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: Jesse Spangenberger <azulephoenix@gmail.com>
# Contributor: Tristelune <tristelune@archlinux.info>
pkgname=pdfstudio
-pkgver=12.0.6
-_pkgver=v12_0_6
+pkgver=18.0.0
pkgrel=1
pkgdesc="Review, annotate, and edit PDF Documents"
arch=('i686' 'x86_64')
url="http://www.qoppa.com/pdfstudio/"
license=('custom')
-conflicts=('pdfstudio11' 'pdfstudio8' 'pdfstudio9' 'pdfstudio10')
+conflicts=('pdfstudio12' 'pdfstudio11' 'pdfstudio8' 'pdfstudio9' 'pdfstudio10')
provides=('pdfstudio')
makedepends=('pacman>=4.2.0')
depends=('java-runtime>=6' 'desktop-file-utils')
@@ -18,19 +17,19 @@ install=${pkgname}.install
sha256sums=('454fbc31f8951f3affcaa0c432b78591a3012a428768f196face44c03b5709ec'
'b82acfb50e1e15a43c54aba7a0712b6c710c10ae74280a26a451343720e965e3'
'0a3c1c337a22228f3df28412ca65d45d0d8067b508cf7b1cf93810fc17c9b447')
-sha256sums_i686=('98e2f0ba0356e6fa07ba7fad90c70546ded14a4d707b14ca87b0a9dcb836afa2')
-sha256sums_x86_64=('c9c924b6e94881684971ada4620d59f5688ce1903cd3df42c7ed568aff62e8b9')
-source_i686=("http://download.qoppa.com/pdfstudio/v12/PDFStudio_${_pkgver}_linux.deb")
-source_x86_64=("http://download.qoppa.com/pdfstudio/v12/PDFStudio_${_pkgver}_linux64.deb")
+sha256sums_i686=('40b9bb9dffa0835474c55bd7c86953e9f65f2ea31511cde47d344535c2ee055f')
+sha256sums_x86_64=('5bc39f23b87dab85ded2062a9b98adade8b03db0e002e586cae8728d2b3ab9b1')
+source_i686=("http://download.qoppa.com/pdfstudio/PDFStudio_linux.deb")
+source_x86_64=("http://download.qoppa.com/pdfstudio/PDFStudio_linux64.deb")
source=(${pkgname}.desktop
${pkgname}.install
${pkgname}.png)
prepare() {
bsdtar xf data.tar.gz
- bsdtar xf "opt/pdfstudio12/lib/pdfstudio.jar" resources/license.html
+ bsdtar xf "opt/pdfstudio/lib/pdfstudio.jar" resources/license.html
- rm -rf "opt/pdfstudio12/jre"
+ rm -rf "opt/pdfstudio/jre"
}
package() {
@@ -44,5 +43,5 @@ package() {
cp -r opt/ "${pkgdir}"
mkdir -p "${pkgdir}/usr/bin"
- ln -s /opt/pdfstudio12/pdfstudio12 "${pkgdir}/usr/bin/pdfstudio"
+ ln -s /opt/pdfstudio/pdfstudio "${pkgdir}/usr/bin/pdfstudio"
}