summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2013-11-03 01:09:52 +0100
committerHyacinthe Cartiaux2015-06-09 14:05:39 +0200
commit6be9f823c5c6038bcea749367d292fd9499ec241 (patch)
treecdbca7d43be539779c8b58278bf0ac9a8ec0319a /PKGBUILD
downloadaur-6be9f823c5c6038bcea749367d292fd9499ec241.tar.gz
[pdsh-genders] Import from AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b06671585eb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: sh0 <mee@sh0.org>
+
+pkgname=pdsh-genders
+pkgver=2.22
+pkgrel=1
+pkgdesc='A high-performance, parallel remote shell utility'
+url='https://computing.llnl.gov/linux/pdsh.html'
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'openssh' 'readline' 'genders')
+optdepends=('perl: required by the dshbak utility')
+options=('libtool')
+source=("http://downloads.sourceforge.net/pdsh/pdsh-${pkgver}.tar.bz2")
+conflicts=('pdsh')
+md5sums=('151b7a67079e88da0309a5c60432f4a9')
+
+build() {
+ cd "${srcdir}/pdsh-${pkgver}"
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --without-rsh \
+ --with-ssh \
+ --without-machines \
+ --without-dshgroups \
+ --without-netgroup \
+ --with-genders \
+ --with-readline || return 1
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/pdsh-${pkgver}"
+ make DESTDIR="${pkgdir}/" install || return 1
+ rm -fr "${pkgdir}/usr/sbin"
+}
+
+# vim:set ts=2 sw=2 et: