summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUncle Hunto2015-08-11 16:48:00 -0700
committerUncle Hunto2015-08-11 16:48:00 -0700
commit6851e878722cdc65e67eae62481e820b7a24cd36 (patch)
tree8f67ccf40b313f95cbad6532a17c3d97e9bac2bc /PKGBUILD
downloadaur-6851e878722cdc65e67eae62481e820b7a24cd36.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e0625f28fa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Uncle Hunto <unclehunto äτ ÝãΗ00 Ð0τ ÇÖΜ>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: TuxSpirit <tuxspirit@archlinux.fr>
+
+pkgname=peazip-qt
+pkgver=5.7.0
+pkgrel=1
+pkgdesc="QT archiver utility"
+arch=(i686 x86_64)
+url=http://www.peazip.org/peazip-linux.html
+license=(LGPL3)
+depends=(balz desktop-file-utils lib32-curl lib32-gmp4 lib32-libx11 lib32-ncurses qt4pas p7zip upx lrzip)
+[[ $CARCH == "i686" ]] && depends=(${depends[@]/lib32-/})
+optdepends=(quad unace)
+provides=(${pkgname%-*})
+conflicts=("${pkgname%-*}-gtk2" "${pkgname%-*}-qt-build")
+install=${pkgname%-*}.install
+source=("$pkgname-$pkgver.tgz"::"https://github.com/giorgiotani/PeaZip/releases/download/$pkgver/${pkgname%-*}-$pkgver.LINUX.Qt.tgz"
+ ${pkgname%-*}.desktop)
+noextract=($pkgname-$pkgver.tgz)
+sha256sums=('13a7de32b09b973e2e540b0ec1247b45d10c6db76f9c9b981df27a4685afc8a9'
+ '4d876c6a61f25a7e2f3dfa69b1c80e61fdda9220bbf8e23a407e34eae377091b')
+sha512sums=('3782083e6959cc00dd2ab6c81743dceb71e5f573299f9d5d0e281fabafc3655257805fc916f9a64d8e282e3565e464838a9c7c6843bbd1382f603174e15c1138'
+ 'bc86d42b33285c2709081ddca7c06fe789cc2d42c69c4cbed595c077a776d91e5526eb799dcdc404375a3bfb212927165a02d3d79301f53adb8a89039bf7bb5f')
+
+
+
+package() {
+ _resdir="$pkgdir"/usr/lib/${pkgname%-*}/res/
+
+ install -d $pkgname/
+ cd $pkgname/
+ bsdtar -xf ../$pkgname-$pkgver.tgz
+ cd usr/local/share/PeaZip/res/
+
+ install -Dm755 ../${pkgname%-*} "$pkgdir"/usr/lib/${pkgname%-*}/${pkgname%-*}
+
+ for i in pea pealauncher rnd; do
+ install -Dm755 $i "$_resdir"/$i
+ done
+ for i in arc/{arc,*.sfx}; do
+ install -Dm755 $i "$_resdir"/$i
+ done
+ for i in altconf.txt lang/* themes/{{nographic,seven}-embedded/*,*.7z} arc/arc.{ini,groups}; do
+ install -Dm644 $i "$_resdir"/$i
+ done
+
+ install -d "$_resdir"/7z/Codecs/
+ for i in 7z{,a,r,.so,Con.sfx,.sfx} Codecs/Rar29.so; do
+ ln -sf /usr/lib/p7zip/$i "$_resdir"/7z/$i
+ done
+ for i in quad/{balz,quad} unace/unace upx/upx lpaq/lpaq8 paq/paq8o zpaq/zpaq; do
+ install -d "$_resdir"/$(dirname $i)/
+ ln -sf /usr/bin/$(basename $i) "$_resdir"/$i
+ done
+ install -d "$pkgdir"/usr/bin/
+ for i in /usr/lib/${pkgname%-*}/{${pkgname%-*},res/pea,res/pealauncher}; do
+ ln -sf $i "$pkgdir"/usr/bin/$(basename $i)
+ done
+
+ install -Dm644 "$srcdir"/$pkgname/usr/local/share/icons/${pkgname%-*}.png "$pkgdir"/usr/share/pixmaps/${pkgname%-*}.png
+ desktop-file-install "$srcdir"/${pkgname%-*}.desktop --dir "$pkgdir"/usr/share/applications/
+ }