summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2015-07-07 14:52:59 +0200
committeraksr2015-07-07 14:52:59 +0200
commitb3612baeadeda444645d838c03f8680a6edeab95 (patch)
treedc97b2340ec7df74a1f3d8b9edf7a247d8a654e8 /PKGBUILD
downloadaur-b3612baeadeda444645d838c03f8680a6edeab95.tar.gz
Start.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a82755fbe830
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: kusakata <shohei atmark kusakata period com>
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=peco-git
+pkgver=0.2.0.6.g32481b1
+pkgrel=1
+pkgdesc="Simplistic interactive filtering tool."
+arch=('i686' 'x86_64')
+url="https://github.com/peco/peco"
+license=('MIT')
+makedepends=('git' 'go')
+provides=('peco')
+conflicts=('peco')
+_gourl="github.com/peco/peco/cmd/peco"
+
+build() {
+ GOPATH=$srcdir go get -v -d -x $_gourl
+ cd $srcdir/src/$_gourl
+ GOPATH=$srcdir go build -o ../../../../../../peco
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 peco "$pkgdir/usr/bin/peco"
+ cd "$srcdir/src/github.com/peco/peco"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+