summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Wolfer2015-12-30 10:17:35 +0100
committerPhilipp Wolfer2015-12-30 10:17:35 +0100
commite749a7b0cae6551a51579625f054939a0fef33a4 (patch)
tree4970aeda82661299509bf06a4b47f777a13641e6 /PKGBUILD
downloadaur-e749a7b0cae6551a51579625f054939a0fef33a4.tar.gz
Initial version to package Peek
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..306f092c0765
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
+pkgname=peek
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Peek - animated GIF recorder"
+arch=('i686' 'x86_64')
+url="https://github.com/phw/peek"
+license=('GPL3')
+depends=(gtk3 ffmpeg imagemagick)
+makedepends=(cmake vala)
+install=peek.install
+source=(git+https://github.com/phw/peek.git)
+sha1sums=('SKIP')
+
+build() {
+ cd "${srcdir}/peek"
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr -DGSETTINGS_COMPILE=OFF .
+ make
+}
+
+#check() {
+# cd "${srcdir}/peek"
+#}
+
+package() {
+ cd "${srcdir}/peek"
+ make install
+}