summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Wolfer2020-03-02 14:34:27 +0100
committerPhilipp Wolfer2020-03-02 14:34:27 +0100
commitf90e8fd2bc9a3e968cbb710404a4eda84bc0fd51 (patch)
tree2b84112b246b5a0dd5e7f3cba98f4d9e416ce165 /PKGBUILD
parent5cc4da62fc4f94d4ad50cf6d7ec4e1af2bc30c74 (diff)
downloadaur-peek-git.tar.gz
Run tests with xvfb-run, bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a4d37286289..70c29ef82d0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
_pkgname=peek
pkgname=${_pkgname}-git
-pkgver=1.3.1.r45.g22b9fe0
+pkgver=1.5.1.r1.ga6a0bcf
pkgrel=1
pkgdesc="Simple screen recorder with an easy to use interface (latest development release)"
arch=('i686' 'x86_64')
@@ -11,6 +11,7 @@ provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
depends=(gtk3 libkeybinder3 ffmpeg)
makedepends=(git meson vala gettext txt2man)
+checkdepends=(xorg-server-xvfb)
optdepends=(
'gst-plugins-good: Recording under Gnome Shell'
'gst-plugins-ugly: MP4 output under Gnome Shell'
@@ -32,7 +33,7 @@ build() {
check() {
cd "${srcdir}/${_pkgname}/builddir"
- ninja test
+ xvfb-run ninja test
}
package() {