summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGraeme Gott2015-06-09 05:30:38 -0400
committerGraeme Gott2015-06-09 05:45:19 -0400
commitd8c91cfe96a8df2e1dcdfca0d9760c1d270f1fa7 (patch)
tree7994cbdfccbb7d6e2564b93a438b97a1fd0aecb1 /PKGBUILD
downloadaur-d8c91cfe96a8df2e1dcdfca0d9760c1d270f1fa7.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7771cf32e0a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Graeme Gott <graeme@gottcode.org>
+
+pkgname=peg-e
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='Peg elimination game'
+arch=('i686' 'x86_64')
+url="http://gottcode.org/$pkgname/"
+license=('GPL3')
+depends=('qt5-base')
+install="$pkgname.install"
+source=("http://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
+sha256sums=('bf96ad7e84f3244f614ccf08c1dbc4f1bdae4bb2cc362a99ecee322ee7e38635')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir/" install
+}