summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatteo De Carlo2015-06-08 22:27:10 +0200
committerMatteo De Carlo2015-06-08 22:27:10 +0200
commit19db991011821a038c9345bb0728377a2323ce2c (patch)
tree101aff5b41700340b53d491ded1e52f504132272 /PKGBUILD
downloadaur-19db991011821a038c9345bb0728377a2323ce2c.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a98398ea403f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+
+# Maintainer: Matteo De Carlo <matteo.dek AT gmail DOT com>
+pkgname=pencil-material-icons-git
+pkgver=1.1.0.r0.g47d2800
+pkgrel=2
+pkgdesc="All 700+ of Google's Material Design Icons as a Pencil stencil collection."
+arch=(any)
+url="https://github.com/nathanielw/Material-Icons-for-Pencil/"
+license=
+depends=('pencil')
+makedepends=('pacman>=4.1.2' 'git' 'python' 'python-lxml' 'python-cairosvg')
+install=
+changelog=
+_name="Material-Icons-for-Pencil"
+source=("git+https://github.com/nathanielw/${_name}.git")
+noextract=()
+md5sums=('SKIP')
+_installdir="/usr/share/evolus-pencil/content/pencil/stencil/"
+
+pkgver() {
+ cd ${_name}
+ git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
+ [ ${PIPESTATUS[0]} -ne 0 ] && \
+printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ # Downloading material-design-icons submodule
+ cd "$srcdir/${_name}"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/${_name}"
+ python3 generate-xml.py
+}
+
+package() {
+ DESTDIR="${pkgdir}/${_installdir}"
+ cd "${srcdir}/${_name}/gen"
+
+ install -m644 -Dt "${DESTDIR}/${_name}" Definition.xml
+ install -m644 -Dt "${DESTDIR}/${_name}/icons" icons/*
+}