summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Robin2017-07-05 23:33:05 +0200
committerBenjamin Robin2017-07-05 23:33:05 +0200
commit2b8ee98dbade70131a1b4686ebbc1bd1993f92b3 (patch)
tree7b34398088286fb0faa8609f7034d19d4e25f1b4 /PKGBUILD
parent1ddfa5064a9c29634b118c8da2eacdb1630a93d0 (diff)
downloadaur-2b8ee98dbade70131a1b4686ebbc1bd1993f92b3.tar.gz
Use make install instead of manual file copy + Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 6 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a5e3aae24e7..2645db047386 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pencil2d-git
_gitname=pencil2d
pkgver=2443.1d67de07
-pkgrel=1
+pkgrel=2
pkgdesc="Animation/drawing software, that lets you create traditional hand-drawn animation using both bitmap and vector graphics"
arch=('i686' 'x86_64')
url="http://www.pencil2d.org/"
@@ -14,11 +14,10 @@ depends=('ming' 'ffmpeg' 'qt5-svg' 'qt5-multimedia')
makedepends=('git' 'qt5-tools')
provides=('pencil2d')
conflicts=('pencil2d')
+options=('!staticlibs')
install=pencil2d.install
-source=('pencil2d::git+https://github.com/pencil2d/pencil.git'
- 'pencil2d.desktop')
-md5sums=('SKIP'
- '98008076937080db82a939d8129ed2d0')
+source=('pencil2d::git+https://github.com/pencil2d/pencil.git')
+md5sums=('SKIP')
pkgver()
{
@@ -26,18 +25,11 @@ pkgver()
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
-prepare()
-{
- cd "${_gitname}"
- # Translation build is broken
- sed -i "/SUBDIRS/s/l10n//" pencil.pro
-}
-
build()
{
cd "${_gitname}"
msg "Starting qmake..."
- qmake
+ qmake PREFIX=/usr
msg "Starting make..."
make
}
@@ -45,8 +37,6 @@ build()
package()
{
cd "${_gitname}"
- install -D -m755 bin/Pencil2D "${pkgdir}/usr/bin/pencil2d"
- install -D -m644 icons/icon.png "${pkgdir}/usr/share/pixmaps/pencil2d.png"
- install -D -m644 "${srcdir}/pencil2d.desktop" "${pkgdir}/usr/share/applications/pencil2d.desktop"
+ make install INSTALL_ROOT="${pkgdir}"
}